using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\[.*?[^\[]*\]";
string substitution = @"";
string input = @"Duck, Donald [CTO [Enterprise] some] Mouse, Micky [HR Employee Engagement]
Duck, Donald [[Enterprise] some] Mouser, Virus [HR Employee Engagement]
Duck, Donald [[Enterprise] [some]] Random text, Virus [HR Employee Engagement]
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}