$re = '/\s*\[.*?[^\[]*\]/m';
$str = 'Duck, Donald [CTO [Enterprise] some] Mouse, Micky [HR Employee Engagement]
Duck, Donald [[Enterprise] some] Mouser, Virus [HR Employee Engagement]
Duck, Donald [[Enterprise] [some]] Random text, Virus [HR Employee Engagement]
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;