using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SID=\w*";
string input = @"admin.php?user=alireza&sa=y&SID=0ahUKEwiO3u2Ji&access=14587&commment=yes";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}