package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SID=\w*`)
var str = `admin.php?user=alireza&sa=y&SID=0ahUKEwiO3u2Ji&access=14587&commment=yes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}