using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^""].+? .+?\.exe)(?!$)";
string substitution = @"""$1""";
string input = @"C:\Program Files (x86)\InstallShield Installation Information\{50033799-D5D3-4759-9ABD-589AD04F33C1}\setup.exe -runfromtemp -l0x0009 -removeonly
C:\Program Files (x86)\Some Directory\Foo.exe
C:\SomePath\WithoutSpaces\Bar.exe -baz
""C:\Some Path\With Spaces\Qux.exe"" -quux";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}