re = /^([^""].+? .+?\.exe)(?!$)/mi
str = 'C:\\Program Files (x86)\\InstallShield Installation Information\\{50033799-D5D3-4759-9ABD-589AD04F33C1}\\setup.exe -runfromtemp -l0x0009 -removeonly
C:\\Program Files (x86)\\Some Directory\\Foo.exe
C:\\SomePath\\WithoutSpaces\\Bar.exe -baz
"C:\\Some Path\\With Spaces\\Qux.exe" -quux'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result