# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\"\"].+? .+?\.exe)(?!$)"
test_str = ("C:\\Program Files (x86)\\InstallShield Installation Information\\{50033799-D5D3-4759-9ABD-589AD04F33C1}\\setup.exe -runfromtemp -l0x0009 -removeonly\n"
"C:\\Program Files (x86)\\Some Directory\\Foo.exe\n"
"C:\\SomePath\\WithoutSpaces\\Bar.exe -baz\n"
"\"C:\\Some Path\\With Spaces\\Qux.exe\" -quux")
subst = "\"$1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.