import re
regex = re.compile(r"<\?.*[\s\S]*?(?:$|\?\>)")
test_str = ("<?php foo(); ?>\n\n"
"<abc>\n\n"
"<? foo(); ?>\n\n"
"<?php\n\n"
"foo();\n"
"bar();\n\n"
"?>\n\n"
"foo();\n"
"bar();\n\n"
"<? //also short open tag\n\n"
"foo();\n"
"bar();\n\n"
"?><?php\n\n"
"foo();\n"
"bar();\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")