#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^d]|d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*([^di]|i([^ds]|s([^cd]|c([^do]|o([^dr]|r([^d]|d(iscord)*([^adi]|a([^dp]|p[^dp])|i([^ds]|s([^cd]|c([^do]|o([^dr]|r[^d]))))))))))))*(d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*(i((s(c?|cor?))?|scord(iscord)*(ap?|i(s(c?|cor?))?)?))?)?$"
Local $sString = "no match" & @CRLF & _
"" & @CRLF & _
"[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)" & @CRLF & _
"[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)" & @CRLF & _
"[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)" & @CRLF & _
"a[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)" & @CRLF & _
"a[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)" & @CRLF & _
"a[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)" & @CRLF & _
"" & @CRLF & _
"match" & @CRLF & _
"a[totally_malicious](google.com)" & @CRLF & _
"[totally_malicious](google.com)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")