import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^d]|d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*([^di]|i([^ds]|s([^cd]|c([^do]|o([^dr]|r([^d]|d(iscord)*([^adi]|a([^dp]|p[^dp])|i([^ds]|s([^cd]|c([^do]|o([^dr]|r[^d]))))))))))))*(d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*(i((s(c?|cor?))?|scord(iscord)*(ap?|i(s(c?|cor?))?)?))?)?$";
final String string = "no match\n\n"
+ "[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)\n"
+ "[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)\n"
+ "[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)\n"
+ "a[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)\n"
+ "a[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)\n"
+ "a[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)\n\n"
+ "match\n"
+ "a[totally_malicious](google.com)\n"
+ "[totally_malicious](google.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}