import Foundation
let pattern = #"^([^d]|d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*([^di]|i([^ds]|s([^cd]|c([^do]|o([^dr]|r([^d]|d(iscord)*([^adi]|a([^dp]|p[^dp])|i([^ds]|s([^cd]|c([^do]|o([^dr]|r[^d]))))))))))))*(d(d|i(d|s(d|c(d|o(d|rd(iscord)*(d|a(d|pd)|i(d|s(d|c(d|od)))))))))*(i((s(c?|cor?))?|scord(iscord)*(ap?|i(s(c?|cor?))?)?))?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
no match
[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)
[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)
[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)
a[k9_et_PAT](https://cdn.discordapp.com/emojis/1290159554080018432.gif?size=48&animated=true&name=k9_et_PAT)
a[RoloHeadpat](https://media.discordapp.net/stickers/1331814642959515699.png?size=160&name=RoloHeadpat)
a[funny_meme](https://cdn.discordapp.com/attachments/408346996823556097/1357753754514100364/NO-WAY-1743754818196.png?ex=67f2abb8&is=67f15a38&hm=2481a2440e02712ff422d605416d1395c973144e51d2e882e7615fbd15a53372&)
match
a[totally_malicious](google.com)
[totally_malicious](google.com)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)