const regex = /^(((https?|ftps?):\/\/)|(mailto:))[a-zA-Z0-9\.:\/@-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((https?|ftps?):\\\/\\\/)|(mailto:))[a-zA-Z0-9\\.:\\\/@-]*$', 'gm')
const str = `https://www.sample.com
https://www.sample-sample.com
http://www.sample.com
http://www.sample-sample.com
https://sample-sample.com
http://sample-sample.com
ftps://sample-sample.com
ftp://sample-sample.com
ftps://sample.sample.com:3000
ftp://sample.sample.com:3000
http://intranet/index.html
mailto:sample@sample.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}