re = /^(((https?|ftps?):\/\/)|(mailto:))[a-zA-Z0-9\.:\/@-]*$/m
str = 'https://www.sample.com
https://www.sample-sample.com
http://www.sample.com
http://www.sample-sample.com
https://sample-sample.com
http://sample-sample.com
ftps://sample-sample.com
ftp://sample-sample.com
ftps://sample.sample.com:3000
ftp://sample.sample.com:3000
http://intranet/index.html
mailto:sample@sample.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end