use strict;
my $str = 'https://www.sample.com
https://www.sample-sample.com
http://www.sample.com
http://www.sample-sample.com
https://sample-sample.com
http://sample-sample.com
ftps://sample-sample.com
ftp://sample-sample.com
ftps://sample.sample.com:3000
ftp://sample.sample.com:3000
http://intranet/index.html
mailto:sample@sample.com
';
my $regex = qr/^(((https?|ftps?):\/\/)|(mailto:))[a-zA-Z0-9\.:\/@-]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}