using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w*)\s*\(((?:(?>[^(){}]+)|(?1))*)\)|\{((?:(?>[^(){}]+)|(?1))*)\})";
string input = @"function(x){
x_identity=sapply(x, function(i) i*2)
x_squared=sapply(x, function(i){
i^2
}
)
}
x_identity=sapply(x, function(i) i*2)
AF(xxx){asdfasdf=asdfsadf}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}