import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\w*)\\s*\\(((?:(?>[^()\\{\\}]+)|(?1))*)\\)|\\{((?:(?>[^()\\{\\}]+)|(?1))*)\\})";
final String string = "function(x){\n"
+ "x_identity=sapply(x, function(i) i*2)\n\n"
+ "x_squared=sapply(x, function(i){\n"
+ " i^2\n"
+ " }\n"
+ " )\n"
+ "}\n\n"
+ "x_identity=sapply(x, function(i) i*2)\n\n"
+ "AF(xxx){asdfasdf=asdfsadf}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}