import re
regex = re.compile(r"((\w*)\s*\(((?:(?>[^(){}]+)|(?1))*)\)|\{((?:(?>[^(){}]+)|(?1))*)\})")
test_str = ("function(x){\n"
"x_identity=sapply(x, function(i) i*2)\n\n"
"x_squared=sapply(x, function(i){\n"
" i^2\n"
" }\n"
" )\n"
"}\n\n"
"x_identity=sapply(x, function(i) i*2)\n\n"
"AF(xxx){asdfasdf=asdfsadf}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")