#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<meta[^>]+property=["']og:image["'][^>]+content=["']([^"']*)["'][^>]*>"
Local $sString = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xml:lang="ja" lang="ja" dir="ltr" xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head>" & @CRLF & _
"<title>CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)</title>" & @CRLF & _
"<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />" & @CRLF & _
"<meta http-equiv="Content-Style-Type" content="text/css" />" & @CRLF & _
"<meta http-equiv="Content-Script-Type" content="text/javascript" />" & @CRLF & _
"<!-- ※ meta ※ -->" & @CRLF & _
"<meta property="og:locale" content="ja_JP" />" & @CRLF & _
"<meta property="og:url" name="og:url" content="http://www.macotakara.jp/blog/report/entry-31631.html?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A%20macotakara%2FzeST%20%28MAC%E3%81%8A%E5%AE%9D%E9%91%91%E5%AE%9A%E5%9B%A3%20blog%EF%BC%88%E7%BE%85%E9%87%9D%E7%9B%A4%EF%BC%89RSS2%29" />" & @CRLF & _
"<meta property="og:site_name" name="og:site_name" content="Macお宝鑑定団 blog(羅針盤)" />" & @CRLF & _
"<meta property="fb:admins" content="1264128707" />" & @CRLF & _
"<meta name="twitter:site" content="@idanbo" />" & @CRLF & _
"<meta name="twitter:creator" content="@idanbo">" & @CRLF & _
"<meta name="twitter:domain" content="twitter.com/idanbo">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<meta name="twitter:card" content="summary_large_image" />" & @CRLF & _
"<meta property="og:type" name="og:type" content="article" />" & @CRLF & _
"<meta property="og:title" name="og:title" content="CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)" />" & @CRLF & _
"<meta name="twitter:title" content="CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)" />" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<meta property="og:description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />" & @CRLF & _
"<meta name="twitter:description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />" & @CRLF & _
"<meta name="description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />" & @CRLF & _
"<meta property="og:image" name="og:image" content="http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg" />" & @CRLF & _
"<meta name="twitter:image" content="http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg" />" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!-- ※ ogp ※ -->" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")