import Foundation
let pattern = #"<meta[^>]+property=["']og:image["'][^>]+content=["']([^"']*)["'][^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xml:lang="ja" lang="ja" dir="ltr" xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<!-- ※ meta ※ -->
<meta property="og:locale" content="ja_JP" />
<meta property="og:url" name="og:url" content="http://www.macotakara.jp/blog/report/entry-31631.html?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A%20macotakara%2FzeST%20%28MAC%E3%81%8A%E5%AE%9D%E9%91%91%E5%AE%9A%E5%9B%A3%20blog%EF%BC%88%E7%BE%85%E9%87%9D%E7%9B%A4%EF%BC%89RSS2%29" />
<meta property="og:site_name" name="og:site_name" content="Macお宝鑑定団 blog(羅針盤)" />
<meta property="fb:admins" content="1264128707" />
<meta name="twitter:site" content="@idanbo" />
<meta name="twitter:creator" content="@idanbo">
<meta name="twitter:domain" content="twitter.com/idanbo">
<meta name="twitter:card" content="summary_large_image" />
<meta property="og:type" name="og:type" content="article" />
<meta property="og:title" name="og:title" content="CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)" />
<meta name="twitter:title" content="CES2017:OtterBox、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」を展示 | レポート | Macお宝鑑定団 blog(羅針盤)" />
<meta property="og:description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />
<meta name="twitter:description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />
<meta name="description" content="CES2017において、OtterBoxが、様々なモジュールを装着出来るモジュール式iPhoneケース「uniVERSE」の展示を行っていました。 背面にあるスライド式「uniVERSEケースシステム」を使用して、背面の下半分を変更す..." />
<meta property="og:image" name="og:image" content="http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg" />
<meta name="twitter:image" content="http://www.macotakara.jp//blog/archives/001/201701/5871de9fb4929.jpg" />
<!-- ※ ogp ※ -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)