package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(.*?)"`)
var str = `<Element Name=\"elem(1)\"/> <Some Value=\"10\" Unit=\"m\"/> <Element Name=\"elem(2)\"/> <Attr Value=\"40\" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}