re = /"(.*?)"/
str = '<Element Name=\\"elem(1)\\"/> <Some Value=\\"10\\" Unit=\\"m\\"/> <Element Name=\\"elem(2)\\"/> <Attr Value=\\"40\\" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end