$re = '/"(.*?)"/';
$str = '<Element Name=\\"elem(1)\\"/> <Some Value=\\"10\\" Unit=\\"m\\"/> <Element Name=\\"elem(2)\\"/> <Attr Value=\\"40\\" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);