package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"MyId":[1-9][0-9]+$`)
var str = `"OtherId":47
"OtherId":7
"MyId":47
"MyId":7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}