$re = '/^"MyId":[1-9][0-9]+$/m';
$str = '"OtherId":47
"OtherId":7
"MyId":47
"MyId":7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);