// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"MyId":[1-9][0-9]+$"#).unwrap();
let string = "\"OtherId\":47
\"OtherId\":7
\"MyId\":47
\"MyId\":7";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}