package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^A-Z]+)*([0-9]+)`)
var str = `N1H3O1 C2H2
C1H4 H201
C1H1N1 N1H3
C2N1O1P1H3 P5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}