re = /([^A-Z]+)*([0-9]+)/m
str = 'N1H3O1 C2H2
C1H4 H201
C1H1N1 N1H3
C2N1O1P1H3 P5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end