import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "FieldName=[\"'](.*?)[\"']";
final String string = " <dataGridWrapper:DataGridWrapperColumn FieldName=\"DateEcriture\" Title=\"Date\" Visible=\"True\" ReadOnly=\"True\" Width=\"70\" AllowSort=\"False\" DisplayFormat=\"dd/MM/yyyy\"/>\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"CodeJournal\" Title=\"Jrl\" Visible=\"True\" ReadOnly=\"True\" Width=\"50\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoPiece\" Title=\"N° Pièce\" Visible=\"True\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"LibelleEcriture\" Title=\"Libellé\" Visible=\"True\" ReadOnly=\"True\" Width=\"180\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"Debit\" Title=\"Débit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"Credit\" Title=\"Crédit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"SoldeD\" Title=\"Solde Débit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"SoldeC\" Title=\"Solde Crédit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"Lettrage\" Title=\"Lettrage\" Visible=\"True\" ReadOnly=\"True\" Width=\"40\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"LibellePrestation\" Title=\"Prestation\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"EtatPiece\" Title=\"Etat\" Visible=\"True\" ReadOnly=\"True\" Width=\"30\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NomResidence\" Title=\"Résidence\" Visible=\"True\" ReadOnly=\"True\" Width=\"85\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDEcriture\" Title=\"IDEcriture\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDImmeuble\" Title=\"IDImmeuble\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDMandat\" Title=\"IDMandat\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoAvisEcheance\" Title=\"N° Echeance\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoFacture\" Title=\"N° Facture\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoFolio\" Title=\"N° Folio\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoLigne\" Title=\"N° Ligne\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"NumMandant\" Title=\"N° Mandat\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"Pointage\" Title=\"Pointage\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"MarqueeCRG\" Title=\"MarqueeCRG\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
+ " <dataGridWrapper:DataGridWrapperColumn FieldName=\"MarqueeNoLot\" Title=\"MarqueeNoLot\" Visible=\"False\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}