import re
regex = re.compile(r"FieldName=[\"'](.*?)[\"']", flags=re.MULTILINE)
test_str = (" <dataGridWrapper:DataGridWrapperColumn FieldName=\"DateEcriture\" Title=\"Date\" Visible=\"True\" ReadOnly=\"True\" Width=\"70\" AllowSort=\"False\" DisplayFormat=\"dd/MM/yyyy\"/>\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"CodeJournal\" Title=\"Jrl\" Visible=\"True\" ReadOnly=\"True\" Width=\"50\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoPiece\" Title=\"N° Pièce\" Visible=\"True\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"LibelleEcriture\" Title=\"Libellé\" Visible=\"True\" ReadOnly=\"True\" Width=\"180\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"Debit\" Title=\"Débit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"Credit\" Title=\"Crédit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"SoldeD\" Title=\"Solde Débit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"SoldeC\" Title=\"Solde Crédit\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"Lettrage\" Title=\"Lettrage\" Visible=\"True\" ReadOnly=\"True\" Width=\"40\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"LibellePrestation\" Title=\"Prestation\" Visible=\"True\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"EtatPiece\" Title=\"Etat\" Visible=\"True\" ReadOnly=\"True\" Width=\"30\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NomResidence\" Title=\"Résidence\" Visible=\"True\" ReadOnly=\"True\" Width=\"85\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDEcriture\" Title=\"IDEcriture\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDImmeuble\" Title=\"IDImmeuble\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"IDMandat\" Title=\"IDMandat\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoAvisEcheance\" Title=\"N° Echeance\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoFacture\" Title=\"N° Facture\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoFolio\" Title=\"N° Folio\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NoLigne\" Title=\"N° Ligne\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"NumMandant\" Title=\"N° Mandat\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"Pointage\" Title=\"Pointage\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"MarqueeCRG\" Title=\"MarqueeCRG\" Visible=\"False\" ReadOnly=\"True\" Width=\"60\" AllowSort=\"False\" />\n"
" <dataGridWrapper:DataGridWrapperColumn FieldName=\"MarqueeNoLot\" Title=\"MarqueeNoLot\" Visible=\"False\" ReadOnly=\"True\" Width=\"80\" AllowSort=\"False\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")