using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\/).+(?=\/)";
string input = @"www.abc.com/page-names/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}