re = /(?<=\/).+(?=\/)/
str = 'www.abc.com/page-names/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end