$re = '/(?<=\/).+(?=\/)/';
$str = 'www.abc.com/page-names/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you
www.abc.com/pagenames/thank-you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);