$re = '/\b\d{4}(?: \d{4}){3}\b/m';
$str = ' 2131 2312 1231 3675 4397 3868 0
12332312231231233675 4532 232345 55 345235
2131 2312 1231 3675 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);