// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d{4}(?: \d{4}){3}\b").unwrap();
let string = " 2131 2312 1231 3675 4397 3868 0
12332312231231233675 4532 232345 55 345235
2131 2312 1231 3675 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}