re = /\b\d{4}(?: \d{4}){3}\b/m
str = ' 2131 2312 1231 3675 4397 3868 0
12332312231231233675 4532 232345 55 345235
2131 2312 1231 3675 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end