re = /^(([NnSs\+-])?([0-8]?\d(\.\d*)?|90) *([°˚º^~*]*) *([NnSs\+-])*)([,:;\s|\/\\-]+)(([EeWw\+-]*)([0]?\d?\d(\.\d*)?|1[0-7]\d(\.\d*)?|180) *([°˚º^~*]*) *([EeWw\+-]*))$/m
str = '53.651231°N 113.641376°W
57.084599°N 2.783300°W'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end