// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([NnSs\+-])?([0-8]?\d(\.\d*)?|90) *([°˚º^~*]*) *([NnSs\+-])*)([,:;\s|\/\\-]+)(([EeWw\+-]*)([0]?\d?\d(\.\d*)?|1[0-7]\d(\.\d*)?|180) *([°˚º^~*]*) *([EeWw\+-]*))$").unwrap();
let string = "53.651231°N 113.641376°W
57.084599°N 2.783300°W";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}