$re = '/^[(+1]/m';
$str = '(541) 754-3010
+1-541-754-3010
1-541-754-3010
(541) 754 3010
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);