re = /^[(+1]/m
str = '(541) 754-3010
+1-541-754-3010
1-541-754-3010
(541) 754 3010
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end