package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Pyt?`)
var str = `Python language
python algorithm
code Python
Python script
more repetitions Pyttttthon
zero occurrences Py Py-pyPy `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}