re = /Pyt?/m
str = 'Python language
python algorithm
code Python
Python script
more repetitions Pyttttthon
zero occurrences Py Py-pyPy '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end