$re = '/\b\d{2}\.\d{2}\.\d{4}\b/m';
$str = '01.01.2021 05.10.2015 01.01.2111 12345 001 Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);