re = /\b\d{2}\.\d{2}\.\d{4}\b/m
str = '01.01.2021 05.10.2015 01.01.2111 12345 001 Text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end