# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*\S+(*SKIP)(*F)|\d/#/gm;t' <<< "hello23 the2e are 13 5.12apples *specially_x00123 named 31st"