$re = '/\*\S+(*SKIP)(*F)|\d/m';
$str = 'hello23 the2e are 13 5.12apples *specially_x00123 named 31st';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;