use strict;
my $str = 'hello23 the2e are 13 5.12apples *specially_x00123 named 31st';
my $regex = qr/\*\S+(*SKIP)(*F)|\d/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";