using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9a-fA-F]{2}(?:[:-][0-9a-fA-F]{2}){5}";
string input = @"01:23:45:67:89:ab";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}