$re = '/[0-9a-fA-F]{2}(?:[:-][0-9a-fA-F]{2}){5}/';
$str = '01:23:45:67:89:ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);