package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9a-fA-F]{2}(?:[:-][0-9a-fA-F]{2}){5}`)
var str = `01:23:45:67:89:ab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}