#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S+(\-\d+){4}\.google\w*\.com"
Local $sString = "> host 66.249.66.1" & @CRLF & _
"1.66.249.66.in-addr.arpa domain name pointer crawl-66-249-66-1.googlebot.com." & @CRLF & _
"" & @CRLF & _
"> host crawl-66-249-66-1.googlebot.com" & @CRLF & _
"crawl-66-249-66-1.googlebot.com has address 66.249.66.1" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Example 2:" & @CRLF & _
"" & @CRLF & _
"> host 66.249.90.77" & @CRLF & _
"77.90.249.66.in-addr.arpa domain name pointer rate-limited-proxy-66-249-90-77.google.com."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")